Настройка mikrotik с нуля + IP TV multicast

Ранее часто встречал девайсы от компании Mikrotik по работе, но вот пришла пора купить и себе домой, опишу процесс полной настройки сего девайса. Вообще последние девайсы идут уже со стандартным конфигом, но я решил его  немного доработать.

Настройка для версий RouterOS 6.x

1.Начнём с того, что необходимо зайти на роутер и скачать чудную утилиту WinBox с самого микротика. Сделать это можно набрав в адресной строке http://192.168.88.1

start

2.Заходим на сам роутер при помощи WinBox

winbox

Нажимаем на троеточие (цифра 1) далее в листе появится наш микротик, на него можно зайти как по IP нажав на него, так и по маку нажав на мак, далее вводим логин пароль и заходим в настройки.

3.Идём в раздел System -> Reset Configuration и нажимаем кнопку Reset Configuration и ставим галочку No Default Configuration

4.Далее заходим на микротик при помощи WinBox (см. пункт 2).

5. Я бы рекомендовал сразу обновить Mikrotik, но сделать можно и позже, настройки всё равно сохраняются. Обновление Mikrotik и установка доп. пакетов

6.Начнём с того, что нам надо разделить свитч на WAN и LAN. Заходим в раздел Interfaces находим порты с третьего по 5-йи в настройках проставляем мастер порт, на рисунке назван ether2-SS               Теперь все настройки которые мы будем применять для порта 2 (ether2-ss) будут применимы так же для портов с 3 по 5-й, при условии что мы используем одного провайдера и подчинили порты с 3-го по 5-й порту 2.

slave

7.Далее идём в раздел IP -> Addresses и прописываем локальный IP адрес. Adress: 192.168.89.1/27 Network – не трогаем, Interface ether2-SS. Для интерфейса wlan1 (это наш wi-fi) прописываем 192.168.89.33/27. Я специально поделил сети LAN и WLAN дабы по вайфаю не летало лишнего трафика. Если ваш провайдер использует статические IP – так же прописываем IP для интерфейса ether1. Заходим в IP -> Routers и добавляем маршрут, в поле адрес указываем 0.0.0.0/0, в поле Gateway указываем ваш шлюз(делается это только если у вас статический IP адрес). Если же используется DHCP то переходим дальше.

Настройка DHCP-client

Тут всё максимально просто, открываем New Terminal и пишем следующее

/ip dhcp-client
add add-default-route=yes default-route-distance=0 disabled=no interface=ether1 use-peer-dns=yes use-peer-ntp=yes

Включение службы DNS

Что бы роутер мог работать в кач-ве DNS сервера и отвечать на запросы клиентских компьютеров надо в меню IP -> DNS поставить галочку перед Allow Remote Requests. Сами адреса DNS серверов надо указывать вручную только если вы вводите свой внешний IP адрес вручную, если нет, то будут использоваться DNS предоставленные провайдером.

 

Для того, что бы роутер смог автоматически раздавать IP-адреса всем подключенным к нему устройствам, нужно настроить DHCP сервер. Для начала нам надо создать пулы, заходим IP -> Pool  Пишем следующее:

Name pool1

Addresses 192.168.89.2-192.168.89.30 (это для LAN)

Next Pool – none

Следом добавим пул для вайфая

Name pool2

Addresses 192.168.89.34-192.168.89.62 (это для WLAN)

Next Pool – none

Или можно через new terminal

/ip pool
add name=pool1 ranges=192.168.89.2-192.168.89.30
add name=pool2 ranges=192.168.89.34-192.168.89.62

 

Затем необходимо настроить уже сам DHCP Server.

Делается это в меню IP -> DHCP Server. Нажимаем на + и в открывшихся друг за другом окнах указываем следующие данные(добавялем при помощи new terminal):

/ip dhcp-server
add add-arp=yes address-pool=pool1 authoritative=after-2sec-delay \
bootp-support=static disabled=no interface=ether2-local-master \
lease-time=1d name=server1
add address-pool=pool2 authoritative=after-2sec-delay bootp-support=static \
disabled=no interface=wlan1 lease-time=3d name=server2

После произведения всех настроек появится запись созданного DHCP сервера.

Так же необходимо добавить сети в DHCP-Server (Вкладка Networks)

/ip dhcp-server network
add address=192.168.89.0/27 dhcp-option="" dns-server=192.168.89.1 gateway=\
192.168.89.1 ntp-server="" wins-server=""
add address=192.168.89.32/27 dhcp-option="" dns-server=192.168.89.33 gateway=\
192.168.89.33 ntp-server="" wins-server=""

dhcp-serv

В принципе всё сделали, но, нехватает всеми нами любимого NAT

Я думаю скрины не обязательны, делаем через терминал:

/ip firewall nat
add action=masquerade chain=srcnat disabled=no src-address=192.168.89.0/24

 

Многие провайдеры предоставляют клиентам белые IP адреса, на которые может получить доступ любой для получения не санкционированного доступа на устройство. Что бы обезопасить себя от таких проблем следует отключить все службы, предоставляемые устройством, кроме доступа через WinBox. Для этого в меню IP -> Services выбираем нужные все службы по очереди и нажимаем на Х вверху окна. Либо можно закрыть все подключения из сети провайдера к вашему устройству, кроме разрешенных, как это делать будет описано ниже:

/ip firewall filter
add action=drop chain=input disabled=no in-interface=ether1

 

Настройки сетевых интерфейсов и служб произведены. Можно приступить к настройке беспроводного адаптера. Начинать следует с настроек шифрования. Для этого в разделе Wireless на ходим вкладку  Security Profiles заходим в свойства существующего профиля default и производим следующие настройки(или создаём новый профиль и настриваем):

passwlan

Далее идём в раздел Wireless -> interfaces выбираем wlan1 в открывшемся окне нажимаем кнопку Advanced Mode и настраиваем как показано на рисунках.

 

wl1 wl2 wl3 wl4

В заключение настройки устройства нужно указать пароль для доступа на него. Установить пароль можно в меню System ->Users. В списке пользователей выбрать admin, и в свойствах нажать кнопку Password. Откроется окно для ввода пароля, в оба поля нужно ввести одинаковые секретные слова. После нажатия кнопки Ok в окне Change Password и User <admin> нужно закрыть окно винбокса и зайти на него снова, но уже с введением пароля.

Настройка IP TV

Для того что бы подружить Mikrotik и multicast необходимо для начала скачать пакет  multicast, как скачать и установить дополнительный пакеты можно прочитать тут:   http://bg.valec.ru/?p=31

Нам необходимо настроить сам IGMP Proxy (Routing -> IGMP Proxy) настройки можно прописать через терминал (New Terminal в WinBox или обычным телнетом)

/routing igmp-proxy
set query-interval=1s query-response-interval=1s quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 disabled=no interface=ether1-GL threshold=1 \
upstream=yes
add alternative-subnets="" disabled=no interface=ether2-LOCAL threshold=1 \
upstream=no
add alternative-subnets="" disabled=no interface=wlan1 threshold=1 upstream=no

Данными командами мы делаем следующее:

Query-interval=1s интервал времени, который указывает частоту отправки Group-Specific query-response-interval=1s

Далее создаём Upstream интерфейс (т.е интерфейс откуда к нам приходит IP TV)

Далее создаём интерфейсы куда нам надо отдавать IP TV. Т.к  У меня Wi-Fi и кабельная сеть разделены на разные подсети и они не объединенные в bridge необходимо добавить отдельно и LAN и WLAN

Далее нам надо прописать следующее:

/interface wireless
Set 0 multicast-helper=full

Пункт multicast-helper доступен в окне настройки wifi интерфейса после нажатия кнопки advanced. Ну или явно в командной строке после set.

Этот маленький пунктик заставляет ваш миротик отправлять мультикаст пакеты по индивидуальным MAC адресам устройств, которые подключены к сети Wi-Fi.

Добавляем правила Firewall для разрешения multicast трафика

/ip firewall filter
add action=accept chain=input disabled=no protocol=udp
add action=accept chain=input disabled=no protocol=igmp

Напомню что в правилах Firewall любые разрешающие правила должны располагаться до запрещающих правил.

Всё это можно настроить не используя командную строку, через WinBox

 

Запись опубликована в рубрике Mikrotik с метками , , , , , , , . Добавьте в закладки постоянную ссылку.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *